Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently moved my file upload service to a new host, a Windows server (was on CentOS before). I'm running IIS + PHP on it, and moved all the php.ini settings from the previous server to the new one. The problem is, however, that large uploads seem to be timing out. The JS uploader never gets a response from the PHP script, as I guess it times out.

Here are the most common upload related php.ini options I have set:


(I have limited the download sizes in the script, don't worry)

According to online resources and others' problems I've read, those settings should let the uploads finish just fine - and they did on the previous server. Smaller (and quicker?) uploads work just fine, and all the required directories are writeable.

share|improve this question

migrated from Jul 11 '11 at 17:39

This question came from our site for professional and enthusiast programmers.

Look at

search for upload_max_filesize

PHP allows shortcuts for bit values, including K (kilo), M (mega) and G (giga). PHP will do the conversions automatically if you use any of these. Be careful not to exceed the 32 bit signed integer limit (if you're using 32bit versions) as it will cause your script to fail.

I think 5GB is out of range

BTW this question belongs to server fault

share|improve this answer
I tried lowering the limits, but the uploads still seem to fail. And the amounts worked on the previous server (both are 64bit). Also, I wasn't sure if this was a server configuration error or something with PHP, so I wasn't sure where to post this. Thanks anyway. – Miikka Virtanen Jul 11 '11 at 16:58
Tomalak: From what point can I vote to move it ? I dont have enought rep, but I didn't find any information about migrating (voting) – genesis Jul 11 '11 at 17:03
up vote 0 down vote accepted

Solved my problem. Apparently, IIS7 has its own limit for requests. More information here:

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.