Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am running a IIS 7 Server behind an aws load balancer. I am using a Verisign SSL certificate which is installed properly but whenever I put in the URL, or the DNS name of the load balancer I get a 403 error:

error 403 - forbidden: access is denied you do not have permission to view this directory or page using the credentials that you supplied

I can access it just fine from local host, and if I just put the public IP address of the server in it works as well. It just doesn't work through the load balancer. Its like IIS blocks all traffic from it.

I've tried:

Reinstalling the certificate - revoked it rekeyed it Recreating the load balancer with intermediate certs and without intermediate certs.

I got the intermediate certs from: https://knowledge.verisign.com/support/ssl-certificates-support/index?page=content&actp=CROSSLINK&id=AR1409&TID=retailssl

Using a GoDaddy certificate works great but my boss wants us to use verisign.

I followed the steps here to install the certs for the load balancer.

http://www.xdevsoftware.com/blog/post/Upload-IIS-SSL-Certificate-into-Amazon-Elastic-Load-Balancer.aspx

Is there a setting on IIS I can change to allow traffic in from my load balancer?

Thanks!

share|improve this question
    
I found it started working once I updated the DNS entry to point to the loadbalancer. I don't know why exactly, but it is working now. –  ChickenFur Jul 11 '11 at 21:44

1 Answer 1

Check your application pool account (or anonymous user) to see if it has permission to the certs folder...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.