Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have some clients that are connecting fine over VPN to Exchange 2003. Some of the users I have moved over to Exchange 2010 and I've done nothing to set Outlook Anywhere up, as I want the users to connect via VPN.

Now, the users that connect to 2003 and 2010 are non domain members, they either have host files full of all the server addresses (FQDN's too). What's strange is that the 2010 users can't connect at all. Basically says that Exchange is not available.

I have a user or two that were on the LAN when I moved them over and they opened Outlook, all worked fine. They have since gone home, been able to work over VPN for over a week and not had an issue. It almost seems that the initial setup of the user is what's causing this over VPN.

Any clues as to what could be causing this?

Thanks

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Is there any particular reason why you don't want to allow RPC over HTTPS? It's extremely secure and easier for the end user...just sayin.

Besides that, what client version are you using? Is it Outlook 2003? If so, there's an encryption requirement that would cause issues. You'd need to either enable encryption on the client or disable it on the server.

If you're using Outlook 2007 or 2010, it's possible that the clients which were setup in the office were set to use RPC over HTTPS as autodiscover configures this automatically. Did you check those settings on the clients that are not connecting?

Another place to look is DNS. Unless you're using a horrible VPN (Sonicwall?) you should be able to specify a DNS server to give out to VPN clients. You should do this rather than create hosts files as host files are easy to mess up and difficult to update.

share|improve this answer
    
Ah, basically, I tried and I kept hitting the wall of certificate issues. Even when adding them on the client machine, I got issues. So I just need to get this up and running in the interim. The clients are a mix between 2007 and 2010. Strangely, the clients in the office all have the HTTP option ticked in the options. I assume auto discover has done this? Could it be that something isn't enabled to allow pure RPC? –  fdf33 Jul 11 '11 at 23:23
    
Oh, the VPN's that I'm using are Cisco VPN and I've tried connecting into to another firewall using Checkpoint VPN. Nothing is being blocked on either. –  fdf33 Jul 11 '11 at 23:31
    
Along the lines of getting RPC over HTTP working, run the appropriate tests here, which might give you a clue as to what's not working: testexchangeconnectivity.com –  joeqwerty Jul 12 '11 at 0:23
    
@fdf33 - Cisco allows you to specify DNS servers in your ra VPN config. Did you do that? Also, buy a certificate for Exchange. Godaddy makes them incredibly cheap and it's not worth the headache of doing a self-signed certificate. –  Jason Berg Jul 12 '11 at 1:14
    
Do I need a certificate if I don't want to use Outlook Anywhere though? –  fdf33 Jul 12 '11 at 6:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.