Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We develop an application which currently works in 32 bit mode only. It worked fine in RHEL 5 but failed to work in RHEL 6. The reason is RHEL 6 by default is installed with 64 bit libraries only. Moreover, we didn't find a way to choose installation of 32bit runtime environment during or after system installation.

Of course, we did find a way to install three rpm packages with 32 bit libraries required for our application to work. But it looks like unpleasant for our customers (we have to install three rpms from the DVD in the command line). So the question is:

Is there a convenient way for RHEL 6 customers to install 32 bit libraries it their RHEL 6 system? Say, any user-friendly item in menu or a special command that install the same set of 32 bit system libraries that existed in RHEL 5? What are best practicies in such cases?

share|improve this question
2  
which 32-bit packages do you need? RHEL makes many 32-bit libraries available for their 64-bit systems. For example, yum search libstdc++ yields both an x86_64 package and an i686 package. –  Chad Feller Sep 6 '11 at 2:21
    
user54614 A quite delayed answer but perhaps you will like it. –  Soham Chakraborty Sep 29 '12 at 7:22

4 Answers 4

The fix in RHEL6 or in derivatives of RHEL6 is to add the parameter multilib_policy=all in your /etc/yum.conf file and that should work out.

It will enable fetching packages of all architectures and is not limited to the 64 bit versions only.

share|improve this answer
    
correct answers are always valued! I have removed the "is this correct" bit, since it is OK. –  Paul Wagland Jan 10 '13 at 20:49

I think it is just

yum groupinstall "Legacy Software Support"

That will allow people in 64bit userland to run 32bit apps

yum groupinstall "Legacy Software Development"

That will allow people in 64bit userland to compile 32bit apps

share|improve this answer
    
Looks like this group doesn't exist... [root@rh6q64 ~]# rpm --import /media/RHEL_6.0\ x86_64\ Disc\ 1/RPM-GPG-KEY-redhat-release [root@rh6q64 ~]# yum groupinstall "Legacy Software Support" Loaded plugins: refresh-packagekit, rhnplugin This system is not registered with RHN. RHN support will be disabled. Setting up Group Process Warning: Group Legacy Software Support does not exist. No packages in any requested group available to install or update –  user54614 Jul 14 '11 at 9:45
    
you can do a yum grouplist –  Mike Jul 14 '11 at 12:31

If the rpms are on the dvd, then they're also in the repo, so you should be able to install them with sudo yum install <pkgs>.

Either include instructions in the readme, or provide them with a script + instructions... in the readme.

share|improve this answer
    
Make sense but we don't want to specify packages in <pkgs>. It would be better to install all 32bit userland with one command... –  user54614 Jul 14 '11 at 9:49
compat-libstdc++-296
compat-libstdc++-33

help with java 1.6 32 bit on centos 6.4 64bit

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.