Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having a problem with the permissions for folder redirection. As a result, I did some research and changed my permissions. The NTFS and Share permissions have been configured according to http://support.microsoft.com/kb/274443 and http://support.microsoft.com/kb/288991.

When I create a new profile on the server, the permissions are correct. When I log in as a regular user I do not have permission to the documents folder and the AppData folder. I have not checked other folders.

So.. I compared the permissions from the original folders and the newly created profile folder. They are the same. I rebooted the server (shouldn't matter -- but just in case)..

Even though the NTFS and Share permissions are showing the same on the folder that works and the folder that does not work, the original folders do not work (they do not allow users to view or create files or folders).

I am at a loss now.... Any ideas?

share|improve this question
    
well since your an iphone guy I'm sure your lost! –  tony roth Jul 12 '11 at 16:10
    
just had to do that, anyway when you say "create a new profile" are you saying that you manually create the directory or just editing the profile settings within AD and then just letting the user login to build the actual directory structure? –  tony roth Jul 12 '11 at 16:11

1 Answer 1

You can use on user active directory side Home drive, for example Z: , to map to \server\home\%username% (use % sign to automate username :) ) also , in group policy, choose option on my documents to redirect to users home drive.

This will make when you create AD user to create folder with correct NTFS permissions.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.