Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a server that has a PHP MySQL extension version 5.0.77 while the MySQL version is 5.1.34. Some pieces of software/scripts are warning me that I may have problems.

What kind of problems should I expect and should I be concerned about it? (I'm not running any fancy MySQL queries/commands through PHP.) Is it big deal?

We don't feel like recompling PHP with a newer version of the library and the server admin really had no idea how (although I could probably figure it out).

share|improve this question
    
If you learn that it is a problem, maybe your best bet would be to downgrade MySQL rather than upgrade PHP. Presumably you could do that without having to compile anything. Does your server really need to be running 5.1? –  Ben Dunlap Jun 19 '09 at 21:28
    
No, I suppose there aren't any new features we need, although 5.1 does have some nice features and fixes (specifically related replication) that we will probably find useful in the near future. Mostly, because 5.1 is almost 2 years old, we think it'd probably be a good idea to move up as we don't like staying on old versions. –  Darryl Hein Jun 19 '09 at 21:46
    
Fair enough -- I've just heard bad things about 5.1 and since 5.0 will be supported until the end of 2011, and it's still what ships in major distros like Ubuntu, I would be inclined to stick with 5.0 unless I had a specific need for a feature that is only in 5.1. –  Ben Dunlap Jun 19 '09 at 23:17
    
BTW, 5.1 has only been "released" for six months. Which probably explains why your PHP is configured as it is. –  Ben Dunlap Jun 19 '09 at 23:19

1 Answer 1

up vote 1 down vote accepted

The kind of problem that I would be worried about in that situation -- assuming a superficial test showed that I was at least able to perform some basic queries -- is differences in the handling of obscure corner cases in the application protocol. That is, the kind of thing where you run fine for a month and then some idiosyncrasy of network behavior tickles the problem and things get weird. Just because you don't do anything fancy with MySQL doesn't mean you're safe. It could be that nothing would go wrong, but I certainly wouldn't feel secure running with that mismatch.

If you try it, you should try to make arrangements so that something or someone will remind you that this is the case if you start having weird application failures.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.