Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am using Windows server 2008 & have iis7 installed. I enter the command ping <hostname> and I get the error: Ping request could not find the host name.

When I did ipconfig -all

"C:\Users\Administrator>ipconfig -all

Windows IP Configuration

   Host Name . . . . . . . . . . . . : Decisons_Win2008
   Primary Dns Suffix  . . . . . . . :
   Node Type . . . . . . . . . . . . : Hybrid
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Ethernet adapter Local Area Connection:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Intel(R) PRO/1000 MT Network Connection
   Physical Address. . . . . . . . . : 00-0C-29-F2-71-6A
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::61bc:3d4b:76d1:2387%11(Preferred)
   IPv4 Address. . . . . . . . . . . : 192.168.168.167(Preferred)
   Subnet Mask . . . . . . . . . . . : 255.255.255.0
   Lease Obtained. . . . . . . . . . : 12 July 2011 12:39:28
   Lease Expires . . . . . . . . . . : 13 July 2011 12:39:27
   Default Gateway . . . . . . . . . : 192.168.168.168
   DHCP Server . . . . . . . . . . . : 192.168.168.168
   DHCPv6 IAID . . . . . . . . . . . : 234884137
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-15-A0-D6-B6-00-0C-29-DA-6F-43

   DNS Servers . . . . . . . . . . . : 192.168.19.1
   NetBIOS over Tcpip. . . . . . . . : Enabled

Tunnel adapter isatap.{11E5344A-7083-449F-B326-CECA5F7B43A3}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 9:

   Connection-specific DNS Suffix  . :
   Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
   IPv6 Address. . . . . . . . . . . : 2001:0:4137:9e76:1cbf:e96:3f57:5758(Prefe
rred)
   Link-local IPv6 Address . . . . . : fe80::1cbf:e96:3f57:5758%13(Preferred)
   Default Gateway . . . . . . . . . : ::
   NetBIOS over Tcpip. . . . . . . . : Disabled

Also when I enter the command hostname in the command prompt, I get the correct hostname. Still I am not able to ping the host name. There were posts similar to the problem that I have, I have read those, still could not resolve the issue.

Updates:

@Mark I did not have the DNS server setup on that machine. So did the setup. Followed this link, but seems that I could not configure that correctly. So I'm stuck at the same place.

I am not a server admin guy, like most of you all so not quite clear with the options available like "Server names" & Host (A) records. looks like that's where things went wrong.

@ByITDesign I can't do that as I am not able to ping the server via its machine name for the same machine. I thought I had done that as well, but then realized that it would not be the right thing. So for now I am accessing the server via IP address.

share|improve this question

migrated from stackoverflow.com Jul 13 '11 at 3:38

This question came from our site for professional and enthusiast programmers.

4 Answers 4

The error message means it couldn't find a DNS entry for Decisons_Win2008. You have a DNS server at 192.168.19.1 but it doesn't have an entry for Decisons_Win2008 in it.

What is living on 192.168.19.1? Is that a domain controller? If so then adding Decision_Win2008 to the domain should cause it to automatically update the A record in DNS. Otherwise you need to manually add it to the DNS server.

share|improve this answer

Making the entry in host file on local desktop can also resolve this issue. Make changes in host file located here. C:\Windows\System32\drivers\etc

192.168.X.X servername

share|improve this answer

It may also be possible that your DHCP server 192.168.168.168 may also be providing you the DNS services, in which case you simply need to set your network settings to "Obtain a DNS server dynamically" from within your network adapter settings. It will remove the DNS that you have defined.

Hope that it helps.

share|improve this answer

To solve this problem, I had to configure the firewall of my Windows 2008 Server:

  • I had to go into Start > Control Panel > Windows Firewall > Change Settings > tab "Exceptions" > check "Network Discovery".
  • I had to enable ping requests/responses as well, as described here.
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.