Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have Dell OMSA installed on a PE1850 running Ubuntu Server 10.04 (using these instructions, pretty strait forward: http://ubuntuforums.org/showpost.php?p=2336772&postcount=54). However when starting the OMSA web server (dsm_om_connsrv) I get the following error:

$./dsm_om_connsrv32d start

./dsm_om_connsrv32d: error while loading shared libraries: libstdc++.so.5: wrong ELF class: ELFCLASS64

What does this mean? I think it means that my version of libstdc++5 is a 64 bit copy and this needs a 32 bit copy? Is that correct, and where can I get a 32 bit copy if that is indeed the case?

share|improve this question
    
Solved: Installed libstdc++5 form here packages.debian.org/squeeze/i386/libstdc++5/download using --force-architecture switch with dpkg –  jwbensley Jul 13 '11 at 12:06
    
New problem :) running "/etc/init.d/dsm_om_connsvc start ; ps aux | grep dsm_om_connsrv" shows me it is running with the "-clrun" switch but "netstat -nl" shows one open port on 1311 (the default OMSA port), its "::::1311" which is IPv6 so this is presumably why I can't connect from another machine by browser to 1.2.3.4:1311? –  jwbensley Jul 13 '11 at 12:23
    
Solved: added IPv6 route to server :D Can't mark as answered though I don't have enough rep to do this so soon! –  jwbensley Jul 13 '11 at 13:18

1 Answer 1

up vote 1 down vote accepted

Solved: Installed libstdc++5 form here packages.debian.org/squeeze/i386/libstdc++5/download using --force-architecture switch with dpkg

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.