Sign up ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have installed Adobe ColdFusion builder 2 and was able to set it up, using this tutorial

After I restarted my computer (for some updates to take effect), I am unable start the server I added using ColdFusion Builder (cfserver). I get the following error -

'starting cfusion' has encountered a problem

Ensure that the server is not already running, or another application is not using the WebServer port.

Does anyone know what to do about this? I am completely lost

EDIT: This is the error the console prints out

[cfusion]:07/13 12:50:14 Error [Thread-13] - Platform, Locale, and Platform Name must not be null

share|improve this question

2 Answers 2

up vote 0 down vote accepted

Your ColdFusion server might be running. Go to Services.msc and check whether the ColdFusion service is marked as manual. If it is set to Automatic the ColdFusion server would be started on machine restart.

From CFBuilder, you can use refresh to get the server status. Also, make sure that you are running CFBuilder with Administrator privileges.

Thanks, Sagar.

share|improve this answer
Ah, so it should be set to automatic on services? Didn't occur for me to check that. I've been having this question for a day and you're the first person to get back with a good answer. Thanks. – alex28 Jul 13 '11 at 18:04
Another quick question - I am trying to run a cfm file within a project. When I click the Run button,I get output stating Selected File is not in the document root of the server. If the Project is not in document root, create a linked folder to the document root (Selecting Project Properties > ColdFusion Project). When I did that and added the pathname from Document Root of the Local Server Settings tab of the server (C:\JRun4\servers\cfusion\cfusion-ear\cfusion-war), I still got the same error. Is there anything I should be doing differently – alex28 Jul 13 '11 at 18:33

If it is set to Automatic, change it to manual.

Your files should be in the webroot if you want them to run it. This is true if you're not using CFBuilder also. Linked folder is used to link a directory to the project. Usually the linked folder is inside the webroot and files in the linked folder can be run.

Also, make sure you have associated a server with Project and a valid URL is shown (Project ->Properties)

share|improve this answer
Thanks. Also, right now I am having issues running cfm scripts. I can browse the directory structure within the browser fine (localhost/cfide/..., etc.), but when I try to go to one of the cfm scripts, I get "Server Error "The server encountered an internal error and was unable to complete your request. Could not connect to JRun Server." Is there anything I could do to allow fix this? – alex28 Jul 14 '11 at 14:41
I'm not sure about what you're asking for. Have you started the server? If yes, then all the files in the webroot can be executed on the browser by typing in the URL in the address bar of the browser. Check the server console to ensure that the server is running and see if there are any exceptions. – Sagar H Ganatra Jul 15 '11 at 11:11
I had to go back and re-install everything since weird things started happening after my comp froze (htdocs directory missing in Apache, text input module missing in CFeditor, etc.). I think that problem with being able to browse through the directories but unable to load cfms had to do with McAfee firewall suddenly deciding to zap JRun and Apache for whatever reason. Everything seems fine now, but I am probably going to fall off a cliff again once I start any real development with it. – alex28 Jul 15 '11 at 19:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.