Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a problem with import of 20mb sql dumo by using phpMyAdmin 3.4.1 . As you can see here there are big values for max scipt's execution time. In apache log I see the following:

[Thu Jul 14 16:28:37 2011] [error] [client 195.64.203.162] Premature end of script headers: php, referer: http://hosting-rus.ru/mysql/phpMyAdmin341/db_import.php?db=jbs3&server=1&token=141da7abe59b0f8f53b3ce32fd6f9ead
[Thu Jul 14 16:28:37 2011] [debug] mod_deflate.c(615): [client 195.64.203.162] Zlib: Compressed 624 to 377 : URL /php-bin/php/mysql/phpMyAdmin341/import.php, referer: http://hosting-rus.ru/mysql/phpMyAdmin341/db_import.php?db=jbs3&server=1&token=141da7abe59b0f8f53b3ce32fd6f9ead

And now I have no ideas how to fix this 500 error while import sql dump. Could you help me? TIA!

share|improve this question

1 Answer 1

use tools like bigdump for large SQL dumps.

This allows you to either upload the file on the page or upload it to the server and load it from there. Bigdump will cut the sql file in pieces and insert it bit by bit.

share|improve this answer
    
It's not a good way. On my another server I can upload dumps with size about 40mb and no problems. But here I resolve an internal server error (and 502 bad gateway sometimes). I also can upload dump by using a shell. But the errors described above make me worry about a server:) –  dizpers Jul 14 '11 at 17:20
1  
its probably just the settings in php.ini (max filesize) that are working against u, also uploading big files can cause timeouts on the webserver. –  Goez Jul 18 '11 at 14:48

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.