Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I had a server with perfectly running for months classical LAMP installation on Ubuntu 8.04:

Linux localhost 2.6.24-23-generic #1 SMP Wed Apr 1 21:47:28 UTC 2009 i686 GNU/Linux
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.04
DISTRIB_CODENAME=hardy
DISTRIB_DESCRIPTION="Ubuntu 8.04.4 LTS"

Don't know why I've started apt-get update, apt-get upgrade but everything ended with apt-get dist-upgrade :) Everything gone alright... But now I can't start nor Apache, nor PHP, because PHP was simply deleted. When I'm trying to install it:

> apt-get install php5
<...>

The following packages have unmet dependencies:
  php5: Depends: libapache2-mod-php5 (>= 5.2.4-2ubuntu5.17) but it is not going to be installed or
                 php5-cgi (>= 5.2.4-2ubuntu5.17) but it is not going to be installed
E: Broken packages

When I'm trying to install libapache2-mod-php5:

The following packages have unmet dependencies:
  libapache2-mod-php5: Depends: php5-common (= 5.2.4-2ubuntu5.17) but 5.3.6-6~dotdeb.1 is to be installed
E: Broken packages

I don't know what 5.3.6-6~dotdeb.1 is and where is this package, because I've already removed dotdeb repository from APT sources :/

Tried to do apt-get update, apt-get upgrade, apt-get install php5 php5-common php5-cli with no success...

Don't know what to try next :(

share|improve this question

2 Answers 2

Do this first:

sudo apt-get remove php5-common

Followed by:

sudo apt-get install php
share|improve this answer

It seems like you have installed some dotdeb packages (you can find them here) and after removing the repository urls from sources.list apt cannot find the right packages to satisfy your installation request. My advice is to remove all installed packages from dotdeb and then try again with apt-get install.

To start, try doing this:

dpkg -r php5-common
apt-get install -f
apt-get install --reinstall php5 php5-common php5-cli

Repeat if needed for any other package from dotdeb that you find.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.