Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is probably a superuser.com question, but it isn't online yet.

The PHY on my NIC is blinking on and off ridiculously, and it should always be on. I googled it and found no answers, just questions.

http://www.google.ca/search?hl=en&q=eth0+keeps+restarting&btnG=Google+Search&meta=&aq=f&oq=

This is on Linux (Ubuntu 8.10) with a Broadcom 100Base-T NIC:

lspci output: 01:09.0 Ethernet controller: Broadcom Corporation BCM4401 100Base-T (rev 01)

share|improve this question
add comment

2 Answers

You probably checked this already, but since you didn't mention anything about this... is your networking cable alright? This is usually a symptom of a bad physical connection (cable or connector).

share|improve this answer
add comment

Somewhere in my googling for a solution I came across ethtool. I decided to try disabling the pause auto-negotiation after perusing its man page...

ethtool -s eth0 autoneg off

So far so good; the PHY is not being turned off. I added this command to /etc/rc.local for now, but perhaps there is a better place.

share|improve this answer
    
In that case there's most likely a faulty cable and/or switch (possibly just one port). Try swapping them just in case. –  LapTop006 Jun 20 '09 at 10:54
    
Turns out the ethtool idea doesn't work. I tried a new cable, and a different port on my switch, but that doesn't solve it either. I guess I'll put a different NIC in this server. –  Jerry Penner Jun 24 '09 at 3:18
    
The new NIC with the original cable and switch port work flawlessly. No more messages in /var/log/messages: Jun 23 21:08:17 banjo kernel: [ 404.496415] b44: eth0: powering down PHY Jun 23 21:08:17 banjo kernel: [ 405.000090] b44: eth0: Link is down. Jun 23 21:08:20 banjo kernel: [ 408.000092] b44: eth0: Link is up at 100 Mbps, full duplex. –  Jerry Penner Jun 24 '09 at 5:35
    
Here is the Ubuntu bug report for the Broadcom driver: bugs.launchpad.net/ubuntu/+source/linux/+bug/279102 –  Jerry Penner Jun 24 '09 at 5:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.