Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a working windows deployment server set up on 2008 R2 which can image machines successfully with en-GB images of Windows 7 SP1.

However when I boot into the Install.WIM the Images are all listed as en-US. How do I get them to be listed as en-GB?

enter image description here

share|improve this question

2 Answers 2

up vote 5 down vote accepted
+50

The language value is actually coded into each .wim file. it defaults with a new wim to en-US.

You can use the dism tool in waik to set the language value on the wim image. Specifically the /Set-UILang switch.

Check out the following documentation page for more information:

http://technet.microsoft.com/en-us/library/dd744360(WS.10).aspx

share|improve this answer
    
Thanks nate, a colleague of mine is trying it out now, I'll award the bounty if it works! –  Christopher Edwards Sep 5 '11 at 13:14
    
Were you able to get it to work? –  Nate Sep 7 '11 at 13:45
    
Unfortunately we didn't get to it but it sounds plausible so I have marked the question as accepted and the system seems to have given the bounty. I'll comment back when I know for sure. –  Christopher Edwards Sep 10 '11 at 0:43

I always deploy images in attend mode, using an unattend file with the image built in WAIK. Within the unattend there is a place to set location and language, as it would with an regular install. So from my experience it doesn't matter what the image is listed as on the image selection.

For example I use: For Timezone:

    <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
        <TimeZone>E. Australia Standard Time</TimeZone>
        </component>
</settings>

You can find all the various timezone formats here: http://technet.microsoft.com/en-us/library/cc749073%28WS.10%29.aspx

For locale and language:

<settings pass="oobeSystem">
    <component name="Microsoft-Windows-International-Core" processorArchitecture="x86" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
        <InputLocale>en-au</InputLocale>
        <SystemLocale>en-au</SystemLocale>
        <UILanguage>en-au</UILanguage>
        <UILanguageFallback></UILanguageFallback>
        <UserLocale>en-au</UserLocale>
    </component>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.