Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

(Apologies if this is in the wrong place, seems a better fit here than rather on SuperUser)

We have two HP CP2025 colour printers installed on a Server 2008 Printe Server, both on HP "Universal Printer Driver, PCL 6". When you click on "Properties" > "Advanced" > "Printing Defaults" one has a "Color" tab (where you can select to print in greyscale or not) and one doesn't and I can't for the life of me work out why. The affected printer (and user) will only print in grayscale.

Things I've checked

  • Printer has "color enabled" on the actual physical printer
  • Updated Print Drivers (from Universal PCL 6 > Universal PCL 6 5.1 and again to Universal PCL 6 5.3)
  • Checked if there is a network driver for the printer, not a universal (there isn't)
  • Compared the settings between two printers, nothing out of the ordinary.

This is the tab on one that doesn't appear on the other: enter image description here

share|improve this question
    
This seems like one of those exceptionally rare questions where SF is the technically correct venue, but you might actually have better luck getting an answer on SU. –  womble Jul 15 '11 at 12:58

2 Answers 2

The HP Universal Driver uses SNMP to determine the printers capabilities. You need to ensure SNMP is configured (read-only, community "public" works, but your environment may require a specific, different setting) before you configure the printer on the server. Hit the printer's web interface and verify this:

enter image description here

Then go back to your print server and trigger an automatic config update. Right-click the printer, select "Properties" and choose the "Device Settings" tab. About half way down you should see "Installable Options". Under "Automatic Configuration" select "Update Now". You'll see a progress dialog appear.

enter image description here

You should now be able to see if color ability was detected. Select the "General" tab and check the "Color" entry. If it's "Yes", you're configured correctly. If not, you may have a communication/configuration issue with SNMP.

enter image description here

share|improve this answer
up vote 0 down vote accepted

Infuriatingly, it took us much longer than it should have done to sort this (granted, it was a few wweeks ago but I thought I'd come back and properly answer this).

Basically, under Printer Properties > Device Settings > Installable Options the "Duplex Unit" was set as "Not Installed" and we manually had to set it as "installed"...which is weird, because we could have sworn that this was checked in the past.

Lesson learned: Check it, and check it again. Then get someone else to look over it and check it a third time.

enter image description here

share|improve this answer
    
Interesting that the "Duplex Unit" setting had an effect upon the "color enabled" setting. I'm going to note this, in case we see the similar issues in our UPD environment. Thanks! –  jscott Feb 8 '12 at 2:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.