Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We identified that the daily backup scheduled for our database was not obtained because the tablespace "SYSTOOLSPACE" was offline, so looking in the internet found that could be solved by running the following command

ALTER TABLESPACE SWITCH ONLINE

After that the system needs to be restarted, so we did it with the following command.

RESTART DATABASE

It didn't work and we cannot open connection to the database. When we tried to open a connection the system give us the following error "SQL0980C"

http://publib.boulder.ibm.com/infocenter/db2luw/v9r5/index.jsp?topic=/com.ibm.db2.luw.messages.sql.doc/doc/msql00980c.html

Looking again in the internet we realise we have tablespace corrupt (probably SYSTOOLSPACE but we're not sure of that) and executed the following command: (attach the result report)

db2dart

Any idea how can we do?

Thanks


    _______                    DART                   _______ 

D a t a b a s e A n a l y s i s a n d R e p o r t i n g T o o l

                       IBM    DB2    NT  

DART (V9.5) Report: 2011-07-15-07.51.49.887000

        Database Name: DATABASE
        Report name: DATABASE.RPT
        Old report back-up: DATABASE.BAK
        Database Subdirectory: F:\DB2\NODE0000\SQL00001
        Operational Mode: Database Inspection Only (INSPECT)

____________________________________________

Action option: DB

Warning: The database state is not consistent.

Warning: Errors reported about reorg rows may be due to the inconsistent state of the database. Connecting to Buffer Pool Services...

Database inspection phase start.

  Tablespace file inspection phase start.
  Loading tablespace files.
  Inspecting next tablespace and associated containers.
  Inspecting next tablespace and associated containers.
  Inspecting next tablespace and associated containers.
  3 tablespaces were identified and their containers checked.
  Error: tablespace files corrupt.
  Error: This phase encountered an error and did not complete.
  Tablespace file inspection phase end.

Database inspection phase end.

                 ______________________________________

                DB2DART Processing completed with error!

                              WARNING:                        
                The inspection phase did not complete!         

                               ERROR:
             The tablespace files are damaged or corrupt.
                    The database may not be usable.

              DB2DART Processing completed with warning(s)!
                 Warning(s) detected during processing.
                 ______________________________________

              Complete DB2DART report found in: DATABASE.RPT

_______    D A R T    P R O C E S S I N G    C O M P L E T E    _____
share|improve this question

1 Answer 1

seems like your tablespace containers for the systoolspace are corrupted. I am guessing..maybe a faulty storage (hard drive)?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.