Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Ubuntu 10.04. I have installed Ruby 1.9.2 through rvm and want to serve rails applications with Passenger. However, if I sudo apt-get install libapache2-mod-passenger, it's telling me that ruby, ruby1.8, rubygems, rubygems1.8, irb1.8, rdoc1.8 is about to be installed as well as some other packages. Is there any safe way to avoid installing those, since I already have ruby and rubygems installed and don't need anything for ruby 1.8?

share|improve this question

migrated from stackoverflow.com Jul 16 '11 at 14:58

This question came from our site for professional and enthusiast programmers.

1 Answer 1

up vote 3 down vote accepted

Since you're mixing a ruby installation not coming from apt-get with a package of apt-get, issues will show, like you report.

You can avoid that by installing Passenger gem gem install passenger and proceeding to install the apache module following Passenger instructions:

http://www.modrails.com/install.html

share|improve this answer
    
Are there any downsides of installing ruby with apt-get besides that I won't be able to switch ruby versions like with rvm? –  Artem Pakk Jul 16 '11 at 0:11
    
apt ruby is 1.8, user wants 1.9.2, which is already installed. That is one downside. Usage of RVM doesn't matter, Passenger does not support multiple versions of Ruby at the same time running on the same Apache installation. –  Luis Lavena Jul 16 '11 at 20:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.