Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Connector settings:

<Connector ...
noCompressionUserAgents="gozilla, traviata"

This seems to work for html, but not for css or javascript. compression="force" does work, but compression="on" doesn't. compression="2" doesn't work either, so I don't know what "force" is really doing.

The files in question are about 6k, I've cleared the browser cache, etc.

share|improve this question
Note that in Tomcat 7 this is the default setting, with the addition of application/javascript. – Charles Wood Dec 17 '15 at 20:59
up vote 6 down vote accepted

You should use compressableMimeType, not compressionMimeType, so

<Connector ...
noCompressionUserAgents="gozilla, traviata"
compressableMimeType ="text/html,text/xml,text/plain,text/css,text/javascript"/>

Should do the trick.

share|improve this answer
Perfect, thanks. – Draemon Jul 8 '09 at 23:43

Please use application/javascript instead of text/javascript, as given below: compressableMimeType="text/html,text/xml,text/plain,text/css,application/javascript"

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.