Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I installed PPTP successfully on a Debian 6.0 64-bit machine, and tried to mimic the installation on both a Debian 5.0 machine, and a CentOS machine. However, I get error codes on connecting with both of those latter machines. The error codes are: 809 and 619. They differ as I hit the "retry" button.

I don't understand why it works on Debian 6.0, while the other two don't, even though they have the exact same configuration.

I already verified the ports are open and reachable externally. I did the following to install the VPN software:

Step 1: Installing pptpd – the pptpd is the daemon that runs the pptp server. To install this just use apt-get:

$ aptitude install pptpd

Step 2: Next you will need to modify the pptpd.conf

$ vim /etc/pptpd.conf

Then scroll down to the bottom and modify the following lines with the subnets you would like assigned:

# (Recommended)
#localip 192.168.0.1
#remoteip 192.168.0.234-238,192.168.0.245
# or
localip 10.0.0.1
remoteip 10.0.0.21-41,10.0.0.51

(Recommended) Edit /etc/ppp/options and add google's opendns addresses

ms-dns 8.8.8.8
ms-dns 8.8.4.4

Step 3: The vpn server is now configured and now you must setup authenticated users:

$ vim /etc/ppp/chap-secrets

The config file is very straight forward and I have an example of a user included:

# Secrets for authentication using CHAP
# client server secret IP addresses
johndoe pptpd johndoepassword *

Step 4: When pptpd was installed it started automatically so we will need to restart it to apply the changes:

$ /etc/init.d/pptpd restart

Now, if you would like to add internet access over this vpn, you can do this:

$ vim /etc/sysctl.conf

and find the line for ipv4 forwarding and make sure it = 1:

Uncomment the next line to enable packet forwarding for IPv4

net.ipv4.ip_forward=1

Then use iptables to get the net forwarded:

$ /sbin/iptables -P FORWARD ACCEPT
$ /sbin/iptables --table nat -A POSTROUTING -o eth0 -j MASQUERADE

Update1: Log file sais the following: Couldnt open the /dev/ppp device no such file or directory

snapshot of log

Update2: It seems the kernel is the problem, I received the message "sorry this system lacks ppp kernel support" and since this is a vps running op OpenVZ I can't alter the kernel (OpenVZ kernel is shared). Not wonder the Debian6 one did work, that's a dedicated server. I guess I have to get openvpn working after all :(

share|improve this question
    
Things that would help your question: log messages, your exact configuration and software version on all machines involved, and a citation for that howto that makes up the vast majority of your question. –  womble Jul 17 '11 at 9:47
1  
Oh, and try OpenVPN instead of PPTP -- much less insanity (or at least different insanity). –  womble Jul 17 '11 at 9:48
    
@womble The how-to is here; larmeir.com/2010/03/… -> I wouldn't know where to find log files containing useful info, and what other configuration would you need to know? I did try openvpn before I tried this, couldn't get it working either. –  natli Jul 17 '11 at 10:14
    
Add information to the question, not as comments. If you can't find log files, you really should try superuser instead of this site. –  womble Jul 17 '11 at 11:51
    
@womble I found the log files. –  natli Jul 17 '11 at 23:55
show 1 more comment

1 Answer 1

up vote 0 down vote accepted

It seems the kernel is the problem, I received the message "sorry this system lacks ppp kernel support" and since this is a vps running op OpenVZ I can't alter the kernel (OpenVZ kernel is shared). Not wonder the Debian6 one did work, that's a dedicated server. I guess I have to get openvpn working after all :(

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.