Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I found out a lot of people with the same problem but anybody actually solved it aparently

The thing is that i can send emails to anyone@anywhere but when i send to @mydomain it is sending to /var/mail/root

and in /etc/mail/local-host-names there is just "localhost" written, which i commented and still the same problem

share|improve this question
1  
Details please. SMTP server, config files... –  David Jul 18 '11 at 1:33
    
I use google apps to receive emails, sendmail is using it's default configurations, im on a debian –  Rogério Chaves Jul 18 '11 at 1:38
    
alright i solved using the first solution here: serverfault.com/questions/65365/… but it's not exactly what i want, i want to disable it for all future domains i put on this server –  Rogério Chaves Jul 18 '11 at 1:42

1 Answer 1

I've written a blog post that covers similar problems. Maybe it can be of help to you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.