Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to compile ruby (v1.9.2) on a CentOS 5.6 system (kernel v2.6.18-238.12.1.el5), but keep getting a "executable host ruby is required" error message during make.

Here are the steps:

./configure --prefix=/usr/local/ruby
make

I get the following error (in entirety):

echo executable host ruby is required.  use --with-baseruby option.; false ./tool/generic_erb.rb -c -o known_errors.inc ./template/known_errors.inc.tmpl ./defs/known_errors.def
executable host ruby is required. use --with-baseruby option.

I read the description of what the '--with-baseruby' option does, but it seems circular, b/c I am trying to install ruby. So do I need to do something like:

--with-baseruby=/usr/local/ruby/... ?

Thanks in advance.

share|improve this question
    
This appears to be related to v1.9.2, I was able to compile and make v1.8.7 with no issues. –  Mike Purcell Jul 18 '11 at 21:20
    
Good to know. Thanks for sharing man :) –  Abel Martin Dec 14 '11 at 18:18

2 Answers 2

Ruby 1.9.X requires a ruby version to be installed.

I know, it sucks, it makes no sense but it works like that. You can have an older Ruby 1.9.X or compile a Ruby 1.8.X (that does not have this requirement).

So:

  • Install Ruby 1.8.X
  • Install Ruby 1.9.X
  • Remove Ruby 1.8.X (if it bothers you)
share|improve this answer
up vote 0 down vote accepted

This appears to be related to v1.9.2, I was able to compile and make v1.8.7 with no issues.

Also, I just recently started the process of upgrading my servers from CentOS 5.6 to 6.0 and found this issue didn't not happen again when trying to install ruby v1.9.x+.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.