Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have Postini set up with their extended message discovery service. This requires having our exchange server set up to journal messages to their mail servers. Everything has been set up and working for months. Now, a couple of times an hour a message that we sent them is rejected as being spam. This is fine, since it usually is spam which has somehow got through the filter on it's way in, and we don't want spam in the archive anyway BUT Exchange keeps this message in queue and keeps trying to resend it:

stuck message

After 24 hours, there are hundreds of messages in the queue, and Exchange is accessing the disk constantly. This is a double problem since our Exchange is in a VM, and it is causing performance issues for other VMs. If you manually clear down the queue it's fine again, until the queue refills.

How can I get Exchange to bin the messages it cannot send to Postini?

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

In my opinion, you're looking at this the wrong way round.

Your message discovery service should accept ABSOLUTELY ALL messages sent to it, spam or ham, or it is next to worthless.

If your message discovery service is rejecting spam messages, who knows what else it's rejecting due to false positives. If this discovery service is implemented for legal or compliance reasons, you need to make absolutely sure it accepts whatever the hell is sent to it and you better get that fixed pronto, before you're either audited or have a reason to use the discovery service and find the messages that will save you from a hefty fine were rejected by the service.

Exchange is not at fault here, Postini is.

share|improve this answer
    
I see what you're saying. Fortunately we don't need discovery for legal or compliance reasons, we're not regulated nor audited for anything related to email. I'll try posting in the postini forums. –  Colin Pickard Jul 19 '11 at 10:00
    
I did post in the Postini forums and someone posted a helpful workaround: google.com/support/forum/p/AppSecurity/… –  Colin Pickard Nov 29 '11 at 11:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.