Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My Dell laptop has a NIC and a wireless connection. I'm unable to connect to my primary Domain Controller via the NIC card. I cannot ping the primary DC, but I can ping several other servers including the backup DC. When I click the 'Network' button, I can only see 3-4 machines (out of the two dozen machines on the network). I have internet access. I tried different cables, different switches, different ports in the office and got the same result. I even removed my laptop from the domain and rejoined it. I even removed my laptop from the AD on the primary DC. I tried to update the NIC driver. I also restored to a Restore Point from last week when everything was working properly. My IP address is within the correct range.

However, when I connect to the network wirelessly, I can ping and connect to everything, like I have been able to do so in the past.

share|improve this question
3  
argh. NIC = Network interface Card. Writing 'NIC card' is a bit redundant. –  Zoredache Jul 18 '11 at 20:06
    
Is your computer using DHCP on both Network ports? –  Zoredache Jul 18 '11 at 20:07
1  
Unless you are in an NT4 domain, there is no such thing as Primary of Backup DCs. –  MDMarra Jul 18 '11 at 20:13
    
Sorry about the NIC card redundancy. Yes, both network ports are using DHCP. –  Charles Jul 18 '11 at 21:09
1  
@Zoredache (and those who upvoted your comment), NIC = Network Interface Controller, not card. OTOH, in the case of a laptop the NIC is normally built-in, so it's still wrong to refer to it as a card. –  John Gardeniers Jul 18 '11 at 21:49

3 Answers 3

up vote 2 down vote accepted

The word 'Dell' sets alarm bells ringing for me, as I've had a similar experience, but with a Dell desktop.

It turned out to be a bad driver. Sourcing the driver from the manufacturer of the NIC rather than from Dell resolved the problem for me.

It might not be the problem you are seeing, but it is eerily similar.

share|improve this answer
    
I've seen similar things as well –  Mark Henderson Jul 18 '11 at 22:59
    
I updated the network drivers from BroadCom, but that didn't help. Thanks! –  Charles Jul 21 '11 at 19:35
    
I updated the network drivers from Dell several times (because it kept saying that the installation was not complete). After my last reboot, everything seems to be working. Thanks for your help! –  Charles Jul 26 '11 at 16:56

Have DNS issues been ruled out? Are you receiving the same DNS servers on the wired and wireless interfaces and both resolve your primary domian controller?

share|improve this answer
    
Yes, both wired and wireless interfaces show the primary DC and secondary DC as the DNS servers respectively. I flushed the DNS cache, did IPConfig/release and IPconfig/renew, but to no avail. I've restarted several times as well. Thanks, but it's still not working. –  Charles Jul 18 '11 at 21:14

Have you compared the network / subnet information from your wireless NIC to your wired NIC? Have you used ipconfig /all to ensure that your cards are on the same subnet and you haven't statically set any info to your wired NIC that would cause this issue?

share|improve this answer
    
Yes, the network/subnet info on both ports are correct. They have different IP addresses, but it is in the same subnet. I have not set any static info on the wired NIC. What's puzzling is that it can see some computers but not the primary DC. Thanks, but the problem continues. –  Charles Jul 18 '11 at 21:12

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.