Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

According to this MSDN article I should be able to install Hyper-V Server 2008 R2 as the primary operating system on my computer, then install one or more copies of Windows Server 2008 R2 as virtual machines (Hyper-V again), then configure the VM's to use Dynamic Memory.

If I'm reading this right...

Dynamic Memory is a new Hyper-V feature available in this service pack. It allows the virtualization server to pool memory and dynamically add or remove memory based on virtual machine usage. This allows for higher consolidation ratios of virtual machines on the virtualization server. To use Dynamic Memory, the virtualization server must be running either Windows Server 2008 R2 with SP1 or Hyper-V Server 2008 R2 with this version of the service pack applied.

...the configuration I have should be allowing me to set Dynamic Memory for the two VM's -- but it's not working. The Memory Management and Memory Weight groups aren't even displayed when I select Settings > Hardware > Memory for either one of the VM's.

Is there something else I need to do to create Hyper-V VM's on my server with Dynamic Memory enabled?

share|improve this question
    
did you update the integration components in the guests –  tony roth Jul 19 '11 at 1:59
    
Yes, but my assumption (at this point) is that I somehow missed a step somewhere. I have another server configured with W2K8 as the primary OS running two W2K8 VM's and the Dynamic Memory features work like a charm, so I'm wondering why I can't get DM going with HVS2K8 as the primary OS. –  jerhewet Jul 19 '11 at 12:27
add comment

3 Answers

Dynamic memory was introduced in Windows Server 2008 R2 SP1. Do you have SP1 installed? In order to see it in the user interface, you'll need to install SP1 on the machine running the UI, if that isn't the host machine itself.

share|improve this answer
    
;) Obvious, isn't it ;) –  TomTom Jul 19 '11 at 20:37
    
SP1 updates (R2, 64-bit) are installed for both W2K8 and HVS2K8, as are the integration services. Still no Dynamic Memory. (sigh). –  jerhewet Jul 20 '11 at 2:02
add comment

You must stop the VMs first to make changes to memory and disk space. These options will be grayed out in a running VM.

http://tinyurl.com/dynamic-mem-hyperv

share|improve this answer
    
That's my point -- I don't even have the grayed-out groups when I bring up Settings > Hardware > Memory. All I can do is change the amount of RAM dedicated to the VM. –  jerhewet Jul 19 '11 at 12:21
    
EDIT: Change the amount of physical RAM, not DM RAM. –  jerhewet Jul 19 '11 at 15:18
add comment
up vote 0 down vote accepted

One of the guys I work with was configuring a new set of Hyper-V servers this afternoon, and decided to (re-)check the machines we couldn't configure for dynamic memory... and it seems the Windows Update Fairy has sprinkled some automatic update dust on Hyper-V Server 2008, because the DM RAM settings (that weren't even grayed out to begin with) have magically appeared in the Settings dialog.

Absolutely no idea what else it could be, since we never touch the host OS servers. Must've been something that came down the wire with an automatic update!

So I guess the moral is "Wait long enough and things will mysteriously take care of themselves"? ;-)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.