Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My server has been restarting almost daily, some times twice a day. This started after changing the raid drives with larger drives. My log for the raid says everything is fine and has not had a single issue saving. The Windows event logs have no critical errors and the errors it has none seem to correlate to the times the crashes happen.

The bios clock has also been getting reset with each reboot. That is most likely the cmos battery. Would that cause the whole system to crash? Also it reboots even though it is set to not reset on crash. Just so we don't have this issue. I am wondering if it is from over heating. I am wondering what other info I can gather to help me trouble shoot this. I am looking into logging cpu temp.

share|improve this question
    
A few things we would need to know. Do you have any .dmp files? Also, what's the vendor? I know at least with Dell products you're pretty safe contacting them even if it's out of warrenty and they will assist you with identifying the issue so you can order the correct hardware part if it's a defective peice of harward. If it's HP, good luck, I've had bad results with them even when it's under warrenty. –  Nixphoe Jul 18 '11 at 21:16
    
Also, can you confirm, or clarify if it is crashing, or rebooting? Might check the power to the system, if you have an APC, might check the log of that. –  Nixphoe Jul 18 '11 at 21:20
    
How do I locate my APC log? –  Nicholas Hutto Jul 18 '11 at 21:50
    
If you have an APC UPS, download the PowerChute Business Edition on the server that has the USB/Com cable installed on it. Then run a self test. It won't help for anything in the past, but it'll help identify the issue going forward when it happens again. apc.com/tools/download/… –  Nixphoe Jul 18 '11 at 21:59
add comment

2 Answers 2

From my experience, your CMOS battery can fail and you'll never notice...as long as the machine has power. If everything keeps flipping back, I would definitely check for power loss. Check to make sure your UPS isn't crashing. Check to make sure your power supply isn't failing.

Did you add more drives to the RAID, or just bigger drives? If it was a graphics card or something I might think that you'd simply outstripped your power supply, and it was crashing while under load due to voltage issues. I'd really expect to see RAID errors then, however. I'm surprised you're not seeing them anyway...RAIDs don't like crashes.

share|improve this answer
    
I upgraded the size of the drives that were there from 1 tbs to 2s. Also how would I go about testing the UPS it does not beep at me like it should if it breaks. and other than seeing if a psu turns on I don't really know what else to test I guess maybe a multimeter and the 24 pin plug but what needs to be what. –  Nicholas Hutto Jul 18 '11 at 21:40
add comment

Is this a hardware raid? If so have you checked for firmware updates for the raid card? it's possible that an older firmware might not support the larger drives

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.