Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a working service deployed to weblogic 9.2. We had a server migration, so we moved this application to another server with the same weblogic setup. Now, when I try to access the WSDL, I get 503 Service Unavailable error. It is the same exact application. Any guess as to why this is happening?

share|improve this question

migrated from stackoverflow.com Jul 19 '11 at 7:53

This question came from our site for professional and enthusiast programmers.

2 Answers 2

One thing to definitely check here is that the application's current status is 'Active', not 'Prepared' - I'm likely telling you things you already know, but there's a two-step deployment process in WebLogic Server 9 and beyond, and an application needs to be deployed (targeted to servers and staged by the deployment process) and then activated.

Can you access any other part of the application? What's the web service stack being used? Axis will give you a web application containing test consoles, so it should be possible to access that generated page on the new site to see what kind of response you get.

If none of that behaves, there is a specific debug flag related to HTTP communication which might shed some light - weblogic.servlet.HTTPDebug, which you can enable from inside the Administration Console by going to Servers -> and then clicking the Debug tab.

Let me know if any of that helps.

share|improve this answer

Interesting - 503 means that there is something wrong on the web server.

  1. Does any other application run on this new server ? Can you connect to the url of any other app from your PC ?
  2. Is the application deployed correctly ? What state does it show in the admin console ?
  3. Can you access the WSDL via an ip address from the server it is deployed on (this will eliminate any proxy/dns issue) ?

I know its a lot of things to try, but I'm really grasping at straws here :)

-Kevin.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.