Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a Windows XP Pro SP3 client that I have joined to a Server 2008R2 domain. The client joined the domain with no issues, it has pulled the group policy (for the most part) and I can see it within ADUC. I have two problems I have been unable to solve: a) I cannot remote desktop from any of the servers to the client - but I can go from the client to the servers and b) the client will not appear on my WSUS 3.0 server (that is also 2008R2).

Do I need to create another OU for the XP clients and create a different GP for them?

Thanks!

share|improve this question

2 Answers 2

up vote 1 down vote accepted

"it has pulled the group policy (for the most part) and I can see it within ADUC"

Did it work prior to pulling policies? Build up a new one on the same network but don't add it to the domain. Disable the windows firewall, enable RDP, and try it then with the workstation on a workgroup and pingable (network all correct).

If it works then a GPO is causing the issue.

share|improve this answer
    
Thanks for the idea! I will not be able to have a definitive answer for you until tomorrow, but I'll certainly give it a try. –  Josh Blair Jul 19 '11 at 14:46
    
I concur. I've had large numbers of XP clients in a 2008R2 domain and didn't have issues with WSUS or RDP. The same GPOs can be applied (although you have to be aware that there are many vista-and-later policies that just dont' do anything to an XP machine). –  Kevin Baker Jul 19 '11 at 14:46
    
@kwbaker Good to know that you didn't have any problems with your WSUS. I'm in the process of scrubbing the GPO to make sure I don't have some weird policy set by accident. –  Josh Blair Jul 19 '11 at 14:50
    
@TheCleaner It isn't the GP as I built a clean XP build and it pulled the GP and started pulling updates immediately. My workplace has canned build images and something within the image itself is preventing GP from fully being implemented as well as remote desktop. All the services are started and running; it's a mystery buried deep enough that it'll be quicker for me to make an image using the new build. Thanks to you and Massimo. –  Josh Blair Jul 21 '11 at 12:37
    
Build a new PC with just the XP CD, get it on the network, and then try to RDP to it (just get to a user prompt...if you get that far it is working). If that works, it is as you said. –  TheCleaner Jul 21 '11 at 14:10

Maybe dumb questions, but...

Is Remote Desktop enabled on the client?
Is Windows Firewall configured to let it through? Are the client and the servers on the same network? If there is a router and/or firewall in the middle, does it allow RDP traffic?

share|improve this answer
    
Hey Massimo, thanks for the reply. RD is enabled on the client and Windows Firewall is disabled. There are routers and switches between, but I would assume that to be not an issue since I am able to RD from client to server, just not from server to client. //EDIT// They are on the same network segment/subnet. –  Josh Blair Jul 19 '11 at 13:28
    
Regarding WSUS: Is the client in the appropriate WSUS target group? –  joeqwerty Jul 19 '11 at 13:28
    
@Josh: Regarding RDP: there may be a router ACL that's preventing RDP connections from the server network to the client network (but allowed in the other direction). –  joeqwerty Jul 19 '11 at 13:30
    
joe, I am not targeting. I have GP set to point all clients and servers to the WSUS and the XP client is not appearing in my WSUS console at all. Thanks for the reply. –  Josh Blair Jul 19 '11 at 13:30
2  
Can you RDP to that client from a machine on the same network (like another client)? If you run netstat on the client, does it show TCP port 3389 as being open and listening? –  Massimo Jul 19 '11 at 13:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.