Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I've read through the existing answers to this topic, but I still can't seem to connect. I've created an AWS key and saved to my ~/.ssh folder.

The command:

ssh -i ~/.ssh/jdrake.pem ec2-user@ec2-75-101-217-120.compute-1.amazonaws.com -v

results in:

OpenSSH_5.2p1, OpenSSL 0.9.8r 8 Feb 2011
debug1: Reading configuration data /etc/ssh_config
debug1: Connecting to ec2-75-101-217-120.compute-1.amazonaws.com [75.101.217.120] port 22.
debug1: Connection established.
debug1: identity file /Users/jdrake/.ssh/jdrake.pem type -1
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3p1 Debian-3ubuntu7
debug1: match: OpenSSH_5.3p1 Debian-3ubuntu7 pat OpenSSH*
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_5.2
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Host 'ec2-75-101-217-120.compute-1.amazonaws.com' is known and matches the RSA host key.
debug1: Found key in /Users/jdrake/.ssh/known_hosts:6
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: SSH2_MSG_SERVICE_REQUEST sent
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Offering public key: /Users/jdrake/.ssh/id_rsa
debug1: Authentications that can continue: publickey
debug1: Trying private key: /Users/jdrake/.ssh/jdrake.pem
debug1: read PEM private key done: type RSA
debug1: Authentications that can continue: publickey
debug1: No more authentication methods to try.
Permission denied (publickey).

I've also tried different users (ubuntu, root, jdrake) without success. I am on OSX.

share|improve this question

migrated from stackoverflow.com Jul 20 '11 at 3:07

This question came from our site for professional and enthusiast programmers.

    
You may have better luck getting help with this on the Amazon EC2 forum... or on ServerFault... –  Scrappydog Jul 19 '11 at 19:59
1  
I gave up and tried a different image. That worked. It must have been the username, even though I tried a bunch. –  Jonathan Drake Jul 20 '11 at 1:52
    
Can you close and/or delete the question please ? If you close it, you can probably reply to the question and mark the answer as correct. –  Oct Mar 10 at 17:06

2 Answers 2

From the logs above you are connecting to an Ubuntu machine:

   debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3p1 Debian-3ubuntu7

Therefore the default username for that box will be ubuntu, not ec2-user which is only for Amazon Linux.

share|improve this answer
    
Cool. Please note that the question was asked years ago, so the server has likely been decomissioned by now. Thanks for the effort, anyway :-) –  Felix Frank Aug 11 at 17:43
    
Ah good point - I'll be more careful to check the date first! Thanks –  jas_raj Aug 12 at 8:42
up vote 0 down vote accepted

Closing this because it was 3 years ago and I don't remember the final solution.

share|improve this answer
    
o_O You know, you could have just accepted the answer of the dude who was honestly trying to help. Just saying... –  Felix Frank Aug 12 at 13:00
    
I'm definitely grateful for the answer (thanks @jas_raj!), but my question includes "I've also tried different users (ubuntu, root, jdrake) without success". –  Jonathan Drake Aug 12 at 14:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.