Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am setting Windows Server 2008 R2 as an Application Server (RDP, SeamlessRDP). I was going to first install that app on the server and then provisioning it to the clients.

The problem is that it's 32 bit app and when I'm trying to install it I'm getting:

The version of this file is not compatible with the version of Windows you're running. Check your computer's system information to see whether you need an x86 (32-bit) or x64 (64-bit) version of the program, and then contact the software publisher.

I tried to set compatibility mode with XP SP2 and SP3, tried Windows 2000. Btw, It works perfect on XP SP2, SP3.

The installer is InstallShield. The Windows built in compatibility wizard is didn't work. I played with other settings like "Run as Admin.." and work in 640x480 mode - no results.

Other apps (also 32bit) are working fine

share|improve this question
add comment

2 Answers 2

up vote 3 down vote accepted

The only time I've seen this is when there's a 16-bit application pretending to be a 32-bit (some really old helpdesk software or some PBX telephony tools). Windows 64-bit has no 16-bit support.

It could even be a 32-bit application that is just using a 16-bit installshield program. If that's the case, it should be simple enough to extract the application out of the installshield wrapper and set it up manually.

More details can be found here.

share|improve this answer
    
thanks, trying to install on another machine and copy it to R2 and run it from R2. –  bakytn Jul 20 '11 at 4:50
    
The latter case is especially common; quite a lot of old 32 bit software came with 16-bit installer routines. –  RobM Jul 20 '11 at 5:22
add comment

This has nothing to do with 32 to 64 bit . it has to do with the softwar enot being compatible, and being blacklisted as such, mostly because it was written by people which "got it working" instead of reading the documentation on how it should work.

Get an update from the publisher.

share|improve this answer
    
Unfortunately this is not an option. –  bakytn Jul 20 '11 at 4:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.