Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have seen plenty of threads on this, but nothing seems quite right.

I have an FTP site setup on Windows Server 2008R2 and I need to allow Domain Users to access their folders only.

I have seen this thread How to isolate ftp users in IIS 7? and do have a domain folder under my root that contains the physical user folders.

When I go to login to the FTP at ftp.example.com, I am presented with the login screen as I should, but then when I enter my test domain username test.user and the password it just refreshes the login window (asking me to login again).

I cannot for the life of me figure out what is going on. I have Isolation set to just the directory and no global virtual directories.

Any help would be greatly appreciated. If you need more information let me know as I am not sure what I am missing.

Thanks!

share|improve this question
    
Grab yourself a decent FTP client like FileZilla (not the Server app, the Client). Try to log in and see what the response is from the server. That may give you more insight in to where the problem is. Let us know what the responses are. –  Lewis Jul 21 '11 at 7:47
    
Thanks for the idea... I should have thought of that. Here is the output from FileZilla Connection attempt failed with "EAI_NODATA - No address associated with nodename". I have not seen that before and Google so far has not been that helpful. I'll post back if I find something. –  Siriss Jul 21 '11 at 14:04
    
That error generally means that the FQDN you're attempting to connect to did not resolve. Try using the IP address of the server instead. –  Lewis Jul 21 '11 at 15:22
    
Ok, so I was stupid and did not test it right. Now this is the response I get from filezilla: Response: 220 Microsoft FTP Service Command: USER test.user Response: 331 Valid hostname is expected. Command: PASS ******** Response: 503 Login with USER first. Error: Critical error Error: Could not connect to server –  Siriss Jul 25 '11 at 14:14
    
I am not sure how to format that correctly I apologize. –  Siriss Jul 25 '11 at 14:15

2 Answers 2

up vote 2 down vote accepted

OK, as far as I can gather you have essentially enabled the use of host header names for FTP.

As far as the server is concerned, it can't tell which of the FTP sites that you have configured that it should authenticate against.

Instead of attempting to log in with test.user try instead with ftp.domain.com|test.user (where ftp.domain.com is the name of the host header you have assigned in the binding for that site).

Essentially the domain name listed before the pipe character tells the FTP service which FTP site to look for authentication credentials.

Make that simple change and let me know how you get on.

-Lewis

share|improve this answer
    
Thank you for the answer. I had tried that in the past and when I finally tested it correctly and saw that error, I knew I had been on the wrong track with my trouble shooting. Thanks again for all your help. –  Siriss Jul 25 '11 at 14:48
    
I will mark this because that is the solution if you want to leave the host binding in place. Thanks! –  Siriss Jul 25 '11 at 15:05

Found the solution in another forum by chance! The solution can be found here

It is the third post down. Turns out that the host name needs to be removed from the binding if just one host is desired.

I don't fully understand why, but that is the solution.

share|improve this answer
    
By adding a host header to the FTP site binding, you have essentially enabled the use of multiple FTP sites. In doing so, you must then login using the syntax ftp.domain.com|username. Removing the host header from your single FTP site disables it again. –  Lewis Jul 25 '11 at 14:53
1  
I see. I an now wondering if there is/was something else wrong then, because I did try ftp.domain.com|username earlier. Thanks again for the explanation! –  Siriss Jul 25 '11 at 14:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.