Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have both SVN and Samba running on the same Debian server.

I have a shared folder, dev, in which I have a SVN checkout, example, of a project.

When I ssh to the server, I am able to do a svn up example from within the dev folder, no problem, however, when I connect to the Samba share and do a svn log (with TortoiseSVN in Windows) I get a 'connection refused' error and a note about removing -q from 'ssh' in '[tunnels]', however, I do not have a -q under '[tunnels]'.

This is my smb.conf file:

path = /var/chroot/www-data/
browseable = yes
read only = no
writable = yes
guest ok = no
create mask = 0644
directory mask = 0755
force user = www-data
force group = www-data
mangled names = no
delete readonly = yes

I get the same errors when using Dokan instead of Samba.

share|improve this question
add comment

1 Answer 1

up vote 0 down vote accepted

The problem was not so much Samba as it was SVN.

When I had done the checkout, I had used svn+ssh://localhost/example.com, so when I wanted to do a svn log or other commands from the Windows machine, Tortoise SVN tried to do a log on localhost/example.com, which of course was wrong. Switching to IP address instead of localhost solved the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.