Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have one problem and I hope you could help me.

I disable http and now using only HTTPS- SSL. In httpd.conf I use:

ProxyPass /comp1/ htt_://192.168.1.5/
ProxyPass /comp2/ htt_://192.168.1.6/

Everything works fine, but..

How can I disable default page (index.php)?

http://192.168.1.0/comp1 I go to http://192.168.1.5/ (that's OK)

When I write http://192.168.1.0 in address bar it become index.php page that I don't need !! How to disable that ?


One more question

When I make in ProxyPass some URL, e.g. https://192.168.5.5/apex/f?p=220:1, I have problem with ?

In URL I see that apex/f%3Fp=220:1 is not allowed.

How to repair that? I've added AddDefaultCharset utf-8 in httpd.conf. but it doesn't work or I don't know how to use it.

share|improve this question
    
You should stick with 1 question per question. –  LazyOne Jul 21 '11 at 10:23
add comment

1 Answer 1

Remove your DirectoryIndex line from your configuration, or set it to something that isn't index.php. You'll then either get a directory index (i.e: a listing of the files in that directory), or a Directory Index Forbidden error if you don't have directory indexes enabled (ie: Options -Indexes)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.