Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a Windows 2003 SBS box, running Exchange Server 2003, as expected.

Office PCs can use this fantastically well using Exchange connections, and I've got some POP3 connections from outside too, no problem here.

My iPad can connect to Exchange using an Exchange connection and I can send/receive emails as normal. So, too, does my Windows Mobile 7 device, using an Exchange connection.

However, trying to get my home PC running Outlook 2010 to connect using an Exchange connection is a problem and I keep getting the following error during configuration of the connection inside of Outlook:

"The name cannot be resolved. The connection to the Microsoft Exchange is unavailable. Outlook must be online of connected to complete this action."

If I set the option to always ask for the credentials, I get the following error:

"Outlook cannot log on. Verify you are connected to the network and are using the proper server and mailbox name. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action."

Any suggestions as to resolve this would be greatly appreciated.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

You need to use RPC over HTTP when outside of the office. When using SBS, this should all be setup for you, with the exception of a signed SSL certificate (it's possible to do it without the SSL cert, but it's a pain...for the small price, just buy the cert).

After you have the cert installed, goto the Connection tab under more settings on your Outlook setup. From there, you can configure Exchange Proxy Settings.

share|improve this answer
    
Thanks for the comment. I am looking into this as we speak, but all I can say, is what a steaming pile of poo this is all turning out to be. Editing Registry values, setting options on the server... ball ache, when my devices do it instantly. <disappointed /> –  Brett Rigby Jul 21 '11 at 6:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.