Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to get Ruby 1.8.7 installed on Plesk 9.5.4. I'm currently running 1.8.6 but gem requires a newer version of Ruby to be installed:

/opt/ruby/bin/gem update --system
Updating RubyGems
Updating rubygems-update
ERROR:  While executing gem ... (Gem::InstallError)
    rubygems-update requires Ruby version >= 1.8.7

An the application I am trying to install requires i18n but that cannot be installed because gem is not up to date:

/opt/ruby/bin/gem install -v=0.4.2 i18n
ERROR:  Error installing i18n:
        i18n requires RubyGems version >= 1.3.5

Any help would be greatly appreciated!

OS: Red Hat Enterprise Linux ES release 4 (Nahant Update 6) Kernel: 2.6.9-67.EL (old, I know..)

share|improve this question
up vote 1 down vote accepted

Remove the binary version of Ruby, get the source and install with: ./configure, make, sudo make install. After that, you also can get the RubyGems source code and install with /usr/local/bin/ruby setup.rb.

share|improve this answer
Do I need to remove the binary version or can I build from source over the top? – Prisoner Jul 29 '11 at 10:17
You don't. You can backup the binary version mv /usr/bin/ruby /usr/bin/ruby.bak and create a symlink ln -s /usr/local/bin/ruby /usr/bin/ruby. Try this and let me know if it works. – quanta Jul 29 '11 at 10:28
It seems that your older version (1.8.6) was also compiled from source (with --prefix=/opt/ruby). Take a look at RVM. It allows you to install several different versions of Ruby on one computer. – quanta Aug 2 '11 at 10:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.