Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am trying to remove postgres from my CentOS server completely so I could start from the beginning, I did some seriously demented stuff!!!! one of them is deleting "/etc/init.d/postgres"

But then I cant remove it!! Things smile at me? Impossible!

I did the following command yum remove postgresql*

Removed
   postgresql84-server.x86_64 0:8.4.7-1.el5_6.1
Complete!

Then I wanted to check if it was removed

yum list installed | grep post
postgresql84-server.x86_64               8.4.7-1.el5_6.1               installed

Any help will be greatly appreciated Thanks,

share|improve this question
    
Have you tried removing 'postgresql84-server'? That looks like the package name –  sam Jul 22 '11 at 10:47
    
Yup I tried that with no luck, the package still "installed" –  wael34218 Jul 22 '11 at 10:51

1 Answer 1

up vote 2 down vote accepted

You can force the reinstallation by rpm -e --justdb --nodeps postgresql84-server and then running a yum install postgresql84-server.

share|improve this answer
    
Thanks for the black smile ;) –  wael34218 Jul 22 '11 at 11:05

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.