Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When vim uses the shell given a colon !command, it does so through the /tmp filesystem. How do you force vim to use ~/.vim/tmp/ instead? It also uses /tmp for help files when zcat is required to read some of the manuals.

TMPDIR doesn't work for this case.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

Have you tried setting the TMPDIR environment variable? That's the standard way (across most "Unix style" programs I've had to worry about it for) of specifying an alternate location for temporary files.

share|improve this answer
    
Actually, this works. I was thinking you were referring to vim's 'directory' setting. Thanks. –  atx Jul 23 '11 at 11:57
    
I've clarified my wording to make it clear I was referring to the env var. –  womble Jul 23 '11 at 12:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.