Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Possible Duplicate:
windows 2003 server slow access

I have a Windows 2003 server which has RAID 5 storage which I have set up in the disk management of the motherboard and hard drives use sata 3 which is meant to be 6Gb per second. It also has 8GB RAM and a 6 core 3.3MHz AMD processor with 2 1Gb ethernet PCI cards, which is connected to a 1Gb switch. We run and application from the server which works fine on most workstations but 2 are causing time out problems. They are in totally different parts of the factory the are both on 100Mb ethernet and I think they are connected to the same switch as the server.

I am totally stuck on what could be causing the problem. Do you have to do anything to enable the sata to work at 6Gb?

share|improve this question
add comment

marked as duplicate by John Gardeniers, Sam Aug 4 '11 at 16:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

Have you tested the two workstations network cables and/or their connections to the switch to see if you have a network issue? If other workstations work and these two don't chances are you have no issue with the server but those two workstations.

A simple ping test to the server can show you if you are getting intermittent network failures. A ping like "ping [server address] -l 4096 -t" will fire off 4k packets non-stop and allow you to watch for high ping rates, failed packets and other network weirdness.

share|improve this answer
    
ok thanks i will try that –  kevin babb Jul 24 '11 at 14:56
add comment

Factor-out your storage and make sure that the clients can communicate to the server with purely made-up data. I've used NTttcp from Microsoft for this purpose with good results. Until you know that the network can move data between the hosts in question at a rate you'd expect there's no point in looking at the storage backing the shared files.

Make sure there aren't any driver updates for the NICs in the problematic clients. If there are, apply them and see if things get better.

If you don't get the speed you'd expect move one of the problematic clients onto a known-working network outlet and see if it gets better. Eventually you may end up with the problematic client plugged-in to the same switch with the server computer. If it's still problematic there with updated NIC drivers and a known-good patch cable then you may want to think about booting another OS on the machine to make sure the NIC hasn't physically sustained damage.

share|improve this answer
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.