Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hi I have the following setup :

  • A router that does DHCP
  • a PXE server (VMware workstation Bridged mode)
  • a client I want to boot on (VMware workstation Bridged mode)

I was following this guide on setting up a PXE boot infrastructure but I'm stuck now, since I cannot install DHCP on the PXE server (won't it conflict with my DHCP on my router?) and apperently I need to specify a file it needs to fetch to do a PXE boot.

How can I achieve a working PXE server without the DHCP server being the PXE server itself?

share|improve this question

3 Answers 3

up vote 4 down vote accepted

There is absolutely zero requirement for the DHCP server to be the same machine as the TFTP server (there's no such thing as a "PXE server"). You simply configure the DHCP server to provide the necessary DHCP options for PXE booting. Good luck managing that on a dinky toy consumer router, though.

share|improve this answer
    
basically there is no way that I can do this on my dinky router then ? –  Lucas Kauffman Jul 24 '11 at 10:32
    
I'd say it's incredibly unlikely. I've never seen a consumer CPE with that complete a feature set. –  womble Jul 24 '11 at 10:33
    
might there be a way to statically point to a PXE server and the file ? –  Lucas Kauffman Jul 24 '11 at 10:37
    
No, the DHCP server just flat out will not support it. I'd just turf the dinky toy as your DHCP server and use a real one off the TFTP server -- or chuck your entire PXE infrastructure on a separate physical segment, and still run the PXE over this separate LAN. It works quite well, and VLANs are cheap (especially in virtual gear). –  womble Jul 24 '11 at 10:50
    
got it all up and working now :D only the boot.txt isnt displayed but everything else works fine –  Lucas Kauffman Jul 24 '11 at 16:22
subnet 192.168.51.0 netmask 255.255.255.0 {
       range 192.168.51.64 192.168.51.80;
       filename "pxelinux.0";
       next-server 192.168.51.1;
       option routers 192.168.51.1;
}

It looks like the requirement of the extended DHCP "filename" option rules out most router-based DHCP servers. The typical router-based DHCP server is mainly focused around the minimal functionality of just managing IP addressing.

share|improve this answer

Recently figured out how to do this with a dinky consumer router running DD-WRT.

Go to DNSMasq settings in Services. Make sure DNSMasq is enabled. Then add this line to the box marked "Addition DNSMasq Options":

dhcp-boot=pxelinux.0,,192.168.5.143

Where "192.168.5.143" is the PXE (TFTP) server's address. And "pxelinux.0" is the file to boot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.