Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

First, yes I know I shouldn't use short tags, but they are all through the project I'm currently working on, and I just need it to work.

I have enabled short_open_tag in /etc/php.ini and restarted Apache. When I run phpinfo() I see that it is enabled, however when I run my project, the short tags don't work. I've done some searching, but haven't found any answers. Any ideas?

share|improve this question
    
1) Since short_open_tag config value can be changed anywhere (even from PHP code itself), it is possible that your project explicitly disables them via ini_set(); 2) your site for this project may be configured to use different php.ini (this is unlikely to happen as I expect that you run your phpinfo() test on the same site as project). –  LazyOne Jul 25 '11 at 0:53
    
1) I grepped the project for ini_set and had no luck finding anything, and 2) yeah, I ran phpinfo() from inside the project. –  seth Jul 25 '11 at 13:26
    
Where do you use them (what file extension)? Does full tag works in that file? Otherwise no ideas. –  LazyOne Jul 25 '11 at 13:32
    
They are being used in .php files, full tags are working. I have run this project successfully before. I just switched from Ubuntu to Fedora, and that's when the problem started. –  seth Jul 25 '11 at 14:14

1 Answer 1

The configuration (if it's mod_php, not CGI) may be also changed in the .htaccess files with a php_flag setting. Look there.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.