Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am unable to connect, for example, via http to a brand new installation of 64-bit Windows Server 2008. The server is on a domain, but is not DC (that's another problem altogether).

The IIS7 is running on the server and the website is accessible locally via http://localhost, but when I try to connect from another machine on the same network, the connections is refused, even though Windows Firewall is disabled.

I am able to connect to and browse the shared folders on the server using Windows Explorer, so it is not a physical connection issue. I can ping other machines on the network from the server, but trying to ping the server from another machine results in "Destination host unreachable".

As far as I can tell, the server refuses any TCP connections from any machine. I am thinking, there must be some other configuration setting that I am missing... Please, help.

NS

share|improve this question
    
the firewall is complete off for all profiles? –  tony roth Jul 25 '11 at 3:53
    
Yes, it's completely off in all of them. –  NonSequitur Jul 25 '11 at 4:03
    
when you say same network does that mean same subnet? –  tony roth Jul 25 '11 at 4:30
1  
Do you have any antivirus software on the server or across your network? It may have a built-in firewall that is blocking HTTP inbound (or outbound) –  Ashley Steel Jul 25 '11 at 5:50
    
@Ashley, No, no anti-virus. Other machines communicate just fine, including an ancient W2003 Server. –  NonSequitur Jul 26 '11 at 4:31
show 10 more comments

4 Answers

up vote 0 down vote accepted

Steps to figuring out what was wrong:

  • Checking there was no firewall or antivirus solution with a built-in firewall
  • Checked that file share access was possible via \\<hostname>, \\<hostname>.<domain>.<tld> or \\<ip address>
  • Checked that DNS and WINS registration was working properly and that both contained the correct references to the server in question
    • Ie, does a DNS request on the FQDN resolve the right IP address and does a WINS/NetBIOS request for the hostname resolve the right IP
  • Checked arp -a to ensure that computers communicating with the server were able to see its MAC address correctly
  • Does remote desktop work?
  • Are there any filtering platform warnings or failure audits in the security event log of the server?

In the end, a name change of the machine was necessary to fix. It turns out the name of the machine had been used on the domain in the past and may have some skeletons left around.

Suggestion is to figure out what those skeletons are to help prevent issues like this in the future.

EDIT: Just so its clear, this is a summary from the comments on the original question

share|improve this answer
add comment

I had this problem and it is fixed.

Short answer, it was due COM+. My post here.

share|improve this answer
    
Hmm, I wish this were it, but - alas - no. My symptoms are nowhere near as severe as you describe. Everything seems to be working normally, except for inbound TCP connections. And I seem to have all the registry keys under HKLM\SOFTWARE\Microsoft\EventSystem\<guid>\EventClasses intact. In short, I don't think it's COM+ - and it's a brand-new installation of WS2008R2. –  NonSequitur Jul 27 '11 at 4:13
add comment

Is your server and test machines all in the same subnet, subnet masks and default gateway correct? Are there any static routes in the server? Are there any errors in the event log?

share|improve this answer
add comment

From the command line run "netstat -n -a -b" and check: which addresses are listening on port 80 which process is doing the listening

You bindings for the website may be on the wrong ip address or another app may have already started listening on 0.0.0.0:80 or :80 (i have seen apps like skype grab 80/443 because it is usually open thru the firewall)

W2k8 typically enables ipv6, check out the connections etc to ensure either your ipv4 is enabled or that your test machines are ipv6 enabled

Did you add 'localhost' as the hostname header in the bindings?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.