Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a dev instance of SQL Server 2008 running on a Windows 2003 virtual private server that I can access without problems from SSMS running on my laptop, connected to my wireless network at home.

But, when I take the laptop to my office and connect to the wireless network there I cannot access the database server from SSMS - the connection to the database times out. To connect I need to RDP into the VPS and run SSMS on the remote server.

I've spoken to the admins running the wireless network at the office and ports 1433 and 1434 are open and I shouldn't have any problems.

One of the obvious differences between the two wireless networks is that at home I'm using WPA2 while the office network is still set up with WEP. Is it possible for this to be causing problems?

I'm running Windows 7 Ultimate x64 SP1. The server is Windows Server 2003 R2 x63 Std. Ed. The database is SQL Server 2008 Web Edition (64 bit) 10.0.1600.22.

Any help (thoughts on what could be wrong, or how I can go about troubleshooting this) appreciated.

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

The WiFi's encryption level should be completely transparent to any applications that are communicating over the network. If you take a look at the OSI model, it should show that all the wifi and encryption related stuff is going on in layer 1: the physical layer. Being able to pass any data to the remote system means it is not a physical layer issue.

So I think I can pretty definitively say that the wireless encryption is not your issue.

Now to what your issue is... I'm not sure, but I'm going to say it is probably related to how you are accessing the server.

  1. Are you accessing the remote system by IP or by Name?

    If by name, can you resolve that name into a valid IP (using nslookup)?

  2. Can you telnet into the server on port 1433?

    a. Can you telnet to port 1433 from either or both networks?

  3. Check SQLServer's configuration, it is entirely possible (and indeed likely) that it is not running on port 1433. I believe it attempts to use dynamic port allocation by default. Microsoft has specific instructions on how to get it to use one static port.

share|improve this answer
    
Further to @Tremmors' post, is there wired Ethernet that you can connect your laptop to in order to rule out the WiFi as being problematic? You may find that the Internet firewall isn't configured as they say it is. –  Ashley Steel Jul 25 '11 at 5:56
    
In both cases I'm accessing the server by name, but have tried IP as well with the same problem. I can't seem to telnet into the server on 1433 over the work wireless either. –  user50623 Jul 26 '11 at 21:17
    
No wired Ethernet at work either - maybe I'll find a wireless hotspot to try over. I'm not sure what can of worms I'll be opening then though :) –  user50623 Jul 26 '11 at 21:41
    
If you can't telnet to it, then it 'aint open. Either SQLServer isn't listening on those ports, or there is a firewall blocking your connection from the second network. –  Tremmors Jul 26 '11 at 21:49
    
I've also looked through my Windows firewall settings to see if the work wireless is configured differently to my home wireless settings, but couldn't see anything obvious. Where does Windows Firewall log filtered outbound requests, or is there a smarter way to figure out what's blocking me? Thanks for your help. –  user50623 Jul 27 '11 at 4:06
show 1 more comment

My guess would be firewalling from the "insecure" (and if it's WEP, it truly IS insecure) wireless network.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.