Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am having some trouble with the server that gives me random errors like this:

BUG: soft lockup - CPU#0 stuck for 60s! [events/0:38]

And the it hangs up until I reboot it.

I heard something about disabling ACPI but I don't know how that will affect the server.

So is it safe to give it a try?

share|improve this question
add comment

2 Answers

http://www.novell.com/documentation/suse91/suselinux-adminguide/html/ch09s03.html has a section that says:

Some newer machines (especially SMP systems and AMD64 systems) need ACPI for configuring the hardware correctly. On these machines, disabling ACPI can cause problems.

I don't know if it's still relevant. I didn't find anything similar on Red Hat's site.

I think it is safe to make good backup (after all your machine is locking up, which may eventually lead to problems with data) and try. Worst case, the machine will not boot up. Best case, you'll find a combination of kernel parameters that solves the problem.

If it affects a recent version of CentOS I'd open a bug on Red Hat's Bugzilla. It may happen that you'll help solve some problem in the Linux kernel :).

share|improve this answer
add comment

Is there a BIOS update available for your server? Sometimes those can cure such problems.

Also, is your CentOS updated? What version of CentOS you have, anyway?

Disabling ACPI can be done by passing acpi=off parameter to GRUB kernel line in the boot screen. Just press e in GRUB at your current kernel to edit the boot parameters, then move to kernel line and append acpi=off at the end of that line. Then just press enter and then b to boot.

That change is just temporary and will last until you reboot the server next time. Should you want to make the change permanent (I doubt that...), just edit /boot/grub/menu.lst.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.