Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am sticking with this problem for a couple of hours now and I am just not finding the right hint.

Dom0 is a Debian Squeeze.

I setup a Xen Server on a Dom0 using apt-get.

Dom0 has the ip 178.15.15.15. Server is reachable and works fine. Installation is going thru without any issues.

I have an additional subnet /29. I set up the first ip of the subnet on the Dom0 to be my default gateway for my DomU's later on.

ip addr add 188.40.249.129/29 dev eth0

ip is up and responses to pings, ssh connections etc.

sysctl.conf looks like this:

net.ipv4.ip_forward=1

net.ipv4.conf.all.rp_filter=1

net.ipv6.conf.all.forwarding=1

net.ipv4.conf.default.proxy_arp=1

net.ipv4.icmp_echo_ignore_broadcasts=1

xend-config.sxp is set to:

(network-script network-route)

(vif-script vif-route)

Setting up a DomU is going thru as well. I am adding the ip address 188.40.249.131. Unfortunately the ip address is not responding either outgoing/incoming.

Please note that these are not the real ip addresses.

Thanks for any help!

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

Just found the solution.

Debian supports in /etc/networks/interfaces an option called pointtopoint.

By adding this option with the gateway in the Dom0 and alls DomU's the routing works.

Be advised that on Dom0 you have to put the default gateway and on the DomU's the ip address of the ip address on the Dom0 in the same subnet.

Example: pointtopoint 10.x.x.1

share|improve this answer
add comment

check iptables forward rules. must allow all traffic to vifX

share|improve this answer
    
Didn't I activate this by putting net.ipv4.ip_forward=1 into the sysctl.conf and rebooting the server? Also I am not able to ping from Dom0 to DomU. –  David Jul 26 '11 at 7:42
    
no. forwarding can be enabled, but all packets blocked by iptables. see iptables -L -n –  arheops Jul 26 '11 at 12:14
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.