Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just upgrade my Mac OS to 10.7 Lion.

It has worked well before. But , Only kinit working normally now, can't ssh to my server.

After reinstall the "Mac OS X Kerberos Extras" , nothing better.

Anyone give me a help? Thanks a lot!!

my command line :

Myname$ ssh root@10.3.18.211 -v

......

debug1: Authentications that can continue: gssapi-with-mic,password
debug1: Next authentication method: gssapi-with-mic
debug1:  Miscellaneous failure (see text)
UNKNOWN_SERVER while looking up 'host/10.3.18.211@3.18.211' (cached result, timeout in 1200 sec)

debug1:  An invalid name was supplied
unknown mech-code 0 for mech 1 2 752 43 14 2

debug1:  Miscellaneous failure (see text)
unknown mech-code 0 for mech 1 3 6 1 5 5 14

debug1: Authentications that can continue: gssapi-with-mic,password
debug1:  An unsupported mechanism was requested
unknown mech-code 0 for mech 1 3 5 1 5 2 7

debug1:  Miscellaneous failure (see text)
unknown mech-code 0 for mech 1 3 6 1 5 2 5

debug1: Next authentication method: password
root@10.3.18.211's password:
share|improve this question
1  
Just Follow this link : superuser.com/questions/315164/… –  deemstone Jul 26 '11 at 15:33
add comment

1 Answer 1

You need to SSH to your server's FQDN and not its IP address. Make sure the server's principal name is the FQDN.

share|improve this answer
    
or you can disable strict checking and add IPs to your kerberos as well (but that's ugly) –  Fox Apr 8 '12 at 9:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.