Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am unable to access my IIS website or even the default website. I did a bit of research and checked/selected the option 'Integrate Windows Authentication' in the Properties > Directory Service tab.

From then on I could access the website using localhost. But when I use my hostname, it asks for domain username/password. Why is it so?

I don't understand why am I not able to access my website without checking this option to integrate windows authentication?

My goal is to access the website using both localhost and hostname.

More details on what I did:

I haven't done anything out of world. What I did is: IIS -> Websites -> Create new Website -> Create a working folder -> Set a default page. I restart this website and then click on browse. And I do not see my default page. I had to go to Directory Service tab and select the check box "Integrate Windows Authentication". Then I can see the default page coming. On IE too I can see the default page coming when I use http://localhost. But when I use http://{hostname} it asks for domain username and password. Why???

share|improve this question
    
Double posting is looked down on. –  Nixphoe Jul 26 '11 at 12:30
    
Which IIS? IIS6, IIS7? –  Kev Jul 26 '11 at 12:36
    
Have you enabled anonymous access to the web site? –  Daniel Ball Jul 26 '11 at 14:16
    
Sorry, I had to post this query afresh, as I haven't found enough response on earlier similar posts. –  rajugaadu Jul 27 '11 at 8:50
    
Mine is IIS6. And I have enabled anonymous user access. –  rajugaadu Jul 27 '11 at 8:50
add comment

1 Answer

You probably have a permission missing on the site so that the anonymous user doesn't work. Check the security tab and check which anonymous user is assigned and grant that user read (or write if you need it) permissions to disk. Then it should use the anonymous account, which is the option it will use as long as the anonymous account has enough permissions.

For further details, you can watch week 23 from this series: http://dotnetslackers.com/projects/LearnIIS7/. While it's for IIS7, it's the same concepts for IIS6.

share|improve this answer
    
Hi Scott, I did enable anonymous user. I can see it checked in IIS -> Website -> Properties -> Directory Service -> Edit. I have given read/write permissions to this user on the working folders. I wish I could post a snapshot of the settings. I had edited my Question above ... to help with more details on what I did. –  rajugaadu Jul 27 '11 at 9:23
    
I would check your bindings to make sure that the site that you expect is serving up the request. For example, you can stop the site and refresh for http://{hostname} and make sure that you get a different response. If it still prompts for credentials then it's likely that another IIS site on the server is handling your request. If it's not that, then check processmon (check out week 20 dotnetslackers.com/projects/LearnIIS7). That will let you know which file or folder doesn't have access for the anonymous user. –  Scott Forsyth - MVP Jul 27 '11 at 14:01
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.