Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am not able to get puppet agent running.

I've tried removing /etc/puppet/ssl on the client, and ./puppetca --clean on the server. Nothing worked.

notice: Starting Puppet client version 2.6.8
debug: Using cached certificate for ca
debug: Using cached certificate for nysv0194
debug: Using cached certificate for ca
/usr/lib/ruby/1.8/net/http.rb:586:in `connect': certificate verify failed     (OpenSSL::SSL::SSLError)
    from /usr/lib/ruby/1.8/net/http.rb:586:in `connect'
    from /usr/lib/ruby/1.8/net/http.rb:553:in `do_start'
    from /usr/lib/ruby/1.8/net/http.rb:542:in `start'
    from /usr/lib/ruby/1.8/net/http.rb:1035:in `request'
    from /usr/lib/ruby/1.8/net/http.rb:772:in `get'
    from /usr/lib/ruby/site_ruby/1.8/puppet/indirector/rest.rb:75:in `find'
    from /usr/lib/ruby/site_ruby/1.8/puppet/indirector/indirection.rb:188:in `find'
    from /usr/lib/ruby/site_ruby/1.8/puppet/indirector.rb:50:in `find'
     ... 10 levels...
    from /usr/lib/ruby/site_ruby/1.8/puppet/application.rb:305:in `run'
    from /usr/lib/ruby/site_ruby/1.8/puppet/application.rb:411:in `exit_on_fail'
    from /usr/lib/ruby/site_ruby/1.8/puppet/application.rb:305:in `run'
    from /usr/sbin/puppetd:4
share|improve this question

it is

puppetca --clean

Also are you running the client as root?

share|improve this answer

Here the certificates are kept on /var/lib/puppet/ssl, but I assume yours is on /etc/puppet/ssl. The thing is, was the puppet client stopped when you removed that directory? Because if it wasn't, you'd get such problems indeed.

share|improve this answer
up vote 1 down vote accepted

The hosts were out of NTP sync :P

share|improve this answer

I had a similar problem, and it ended up being due to having multiple versions of puppet installed: one from the Ubuntu repositories and one from a ruby gem. Uninstalling the version from the Ubuntu repository solved the problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.