Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I do not want /home in a separate partition for a new CentOS 6 install. However, there no longer appears to be a "Review and Modify Partition Layout" in the text installer. How can I do this?

EDIT: I'm doing a netinstall, if that makes any difference.

share|improve this question
    
By the way, this doesn't belong here. Should be moved to superuser.com –  akseli Jul 27 '11 at 13:34
    
@akseli: you're right, sorry about that –  BigChief Jul 27 '11 at 14:25

3 Answers 3

up vote 4 down vote accepted

It seems from what I've read online that CentOS 6 doesn't support modifying your partition layout when installing in Text-Mode.

It seems that this option is only available if you're performing a graphical install.

This is covered in the release notes.

CentOS6 Release Notes

share|improve this answer
1  
Since it's not supported by the text installer, just perform the install then remove the partition afterwards. You are using LVM, right? :) –  MikeyB Jul 27 '11 at 14:12
    
Got it, I missed that part of the releasenotes. Unfortunately I don't have access to the graphical install, but I'll do as @MikeyB suggests. Thanks! –  BigChief Jul 27 '11 at 14:19

Starting with RHEL6/Centos6, you need to use the graphical installer to adjust your partition layout. In order to use the graphical installer, you need about 512-1 gig of RAM.

share|improve this answer

As someone else mentioned, you can change it later.

If you are looking at an interactive install, that is the way to go or using GUI, although that is not an option in a lot of farms.

Not sure what your environment is, but you could also get around this by using a kickstart file. You can either create a custom install DVD or via PXE. Just poking around a kickstart file I created on a test box the other day, I see a number of partitioning options..

share|improve this answer
    
I have yet to encounter this because I've been using a kickstart file. This is one of many changes in the new version that seem to be a step backwards, though. –  ewwhite Jul 27 '11 at 14:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.