Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Okay, so up until recently, I've been hosted by someone else. Now, I'm trying out Apache web server (which is restating the obvious, given the title).

I downloaded this one: httpd-2.2.19-win32-x86-openssl-0.9.8r.msi Is it the correct version? I'm running Windows 7 Home Premium.

When I installed it..
network domain: the-social-project.info
server name: the-social-project.info
administrator's email address: myemailadress@yaddayadda.com
I'm not sure if I should make the first two different or not. I followed a tutorial and they put the same thing for both.

Then, the tutorial said for me to go to http://localhost. Bad news here, I ended up with "It works!"

How do I fix this? Please explain it to me in very, very basic terms. I've never hosted myself before.

Thank you for your time!
-Amy

PS: Oh yes. Also, I checked if my port 80 is open-- yes it is. Is it supposed to be?

share|improve this question

migrated from stackoverflow.com Jul 27 '11 at 14:26

This question came from our site for professional and enthusiast programmers.

2  
How is "It works!" bad news? –  T.J. Crowder Jul 26 '11 at 3:25
1  
Ehm. "It works!" is a good thing right? Anyway try looking here: C:\Program Files (x86)\Apache Software Foundation\Apache2.2\htdocs or C:\Program Files\Apache Software Foundation\Apache2.2\htdocs –  Erik Jul 26 '11 at 3:25
2  
Oh no! "It works!" –  Jared Farrish Jul 26 '11 at 3:26
    
I thought it wasn't supposed to show up if the Apache web server was correctly installed. webdesign.about.com/cs/apache/a/aainstapachewin.htm Scroll down to the "Test your Apache Server" part. –  Amy Dee Jul 26 '11 at 3:27
1  
Why are you hosting your website on your home computer? –  Jared Farrish Jul 26 '11 at 3:29

2 Answers 2

Then, the tutorial said for me to go to http://localhost. Bad news here, I ended up with "It works!"

That's good news.

Now you just have to point the server at the directory your web content is located in by either changing the DocumentRoot setting in your httpd.conf file (which should be in the folder Apache installed into, probably somewhere in Program Files), or moving your web content into the existing DocumentRoot location.

share|improve this answer

Amy, this is the expected behaviour for a native apache installation. To answer your questions directly

I'm not sure if I should make the first two different or not. I followed a tutorial and they put the same thing for both.

It doesn't really matter, the servername should be the URL that you want to access your site under if you are going to only host one site on this (virtualhosts kind of fall out of the scope for this)

Then, the tutorial said for me to go to http://localhost. Bad news here, I ended up with "It works!" How do I fix this? Please explain it to me in very, very basic terms. I've never hosted myself before.

This is the correct behaviour, this is the standard Apache page after installation. This would most likely be found at c:\Program Files\Apache Software Foundation\Apache2.2\htdocs this is where you should put your HTML files. Out of the box Apache will only work with HTML, you won't be able to use any dynamic pages like PHP or ColdFusion, these require an application server or page handler to be running as well but again fall outside the scope of this question.

However, I would place a few warnings here. If you are on a consumer internet connection, your ISP may block port 80 as they do not normally want people hosting websites etc on their service, they want you to pay for a business connection. Also, you will have to have your PC on all the time, when your PC is off, your website is off. You need to manage backups, patches, updates and security yourself.

If you are comfortable with all this then have at it, but if you aren't or are only testing and practising, I would recommend getting a hosting company to manage it for you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.