Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a server (Ubuntu 11.04) with a RAID 10 array (4 disks), and the RAID 10 array is partitioned as one big LVM. I have a logical volume on that which is 40GB that holds the root file system. The other LVs are for virtual machine disks. Everything is running fine including the virtual machines.

Here's the problem:

I need more space to work with large files on the host machine. I have extra LVM space, so I thought I'd create an LV and mount it to the host.

So I created a 500GB LV:

lvcreate -L 500G -n extra_space lvm-main

ran mkfs on it to make it an EXT4 file system:

mkfs.ext4 /dev/lvm-main/extra_space/

and mounted it at /extraroom on the host file system (fstab):

/dev/mapper/lvm--main-extra_space /extraroom ext4 errors=remount-ro 0 1

The problem is, as soon as I mount the new LV, the hard drive(s) make a chugging sound like a washing machine, cha-chug... cha-chug... cha-chug... When I unmount the LV, the noise stops. When I remount the LV, it starts chugging again.

I'm thinking there's something wrong with the way this LV is mounted that's causing the disks to move their heads a lot? This is my first time using LVM. Am I doing this wrong, or is it normal to make noise for a while when mounting a new LV to the main file system?


I've run:

smartctl -t short /dev/sda

on all 4 drives which passed. I run the long version on the first two drive which also passed. I'm currently running the long version on the second two drives now (it takes several hours).

After mounting, I found a couple of interesting processes bouncing around in top. (Nothing jumped to the 'top', but I don't think i can sort top by disk io.)

One process is called "ext4lazyinit" which seems suspect to me, since the new LV is supposed to be ext4. Is it trying to format the partition as EXT4 in slow motion? Can I tell it to "get it over with!"?

There's also "sync_supers" I'm not sure what that does.

I tried Googling for "ext4lazyinit" and "sync_supers" and got mostly bug reports, nothing that explained what they do.

I'm letting it run for a while to see what happens. It's been going for about 15 so far, with no change in rhythm.

share|improve this question
In my experience, a rhythmic two-beat chugging sound means the drive is dying. – DerfK Jul 27 '11 at 23:15
After you mount the new LV, do you notice any difference in system performance/responsiveness? Any "interesting" processes leap to the top of 'top'? Have you tried leaving the system relatively quiescent for a while, while it's 'cha-chugging' - say, ten or fifteen minutes - to see if the noise mitigates? – anastrophe Jul 28 '11 at 3:51
I was afraid to let it go on for a while in case it was a mis-configuration (or bug) that was beating my drives to death. I can try mounting the LV and checking top tomorrow and will report back. – Nick Jul 28 '11 at 5:06
found "sync_supers" and "ext4lazyinit". I wonder if that's part of the problem? Please see update above for more details. – Nick Jul 28 '11 at 17:50
Also, it seems to have stopped now after about 45 minutes. Maybe it's just some strange delayed partitioning thing that Ubuntu does? – Nick Jul 28 '11 at 18:18
up vote 0 down vote accepted

Allocating the extra space has made active a part of the disk that is on it's way out. Identify which drive is making the noise and replace it immediately.

share|improve this answer
I bought all 4 disks last week. Any tips on how to figure out which drive is bad? They're in a RAID array so they all act as one disk. – Nick Jul 27 '11 at 23:24
Stick your ear really close to each drive and listen. Or use whatever diagnostics are in your RAID controller to find out which one's failing. – womble Jul 27 '11 at 23:26
SMART short test with "smartctl -t short /dev/sda" reported no errors on any of the drives. I also tried listening and putting a finger on each drive to see which one is doing it, but I think that they are all making the sound when the VM is mounted. – Nick Jul 28 '11 at 0:23
I'm thinking this issue is related to the "ext4lazyinit" process and a delayed ext4 format rather than hardware failure. Please see my comments above. – Nick Jul 28 '11 at 18:53

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.