Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Hi all we are having trouble to create/drop index(s) on a table I keep getting the following error:

  • ERROR 1280 (42000): Incorrect index name '<>'

Now the table has the following: 1. PRIMARY KEY (id), 2. UNIQUE KEY field_one (field_one), 3. KEY EAN (field_two),

Meta Info: - ENGINE=InnoDB AUTO_INCREMENT=23149997 DEFAULT CHARSET=utf8 MAX_ROWS=4294967295 AVG_ROW_LENGTH=50 PACK_KEYS=0

  • About 20 000 000 entries.

Tried thus far: - check table (medium & extended) table is ok

  • optimize table - went fine

  • tried to drop all index(s) but that also doesn't work.

Server info: The server is a MASTER server is running MySQl 5(5.1.51-rel11.5-log) with Percona patches

share|improve this question
    
The error description explains your problem already, I think. When in doubt, post the ALTER TABLE command you are trying to execute. –  sw0x2A Jul 28 '11 at 8:20
    
alter table MyTable drop index <index-name>; –  Koos Jul 28 '11 at 8:35
    
Also, i ran (copy & paste) the exact command on our DEV db and it works there ?? ' –  Koos Jul 28 '11 at 8:38
    
Maybe index name is different? –  sw0x2A Jul 28 '11 at 9:05
    
yip tried that as well :( –  Koos Jul 28 '11 at 9:20

1 Answer 1

Try without <>:

alter table MyTable drop index index-name;
share|improve this answer
    
yes "<>" was just for display –  Koos Jul 28 '11 at 8:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.