Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I added a new Network to a Debian 6.0.1 x86_64 Linux 2.6.32-5-amd64 Server with this configuration in the interfaces:

allow-hotplug eth2
iface eth2 inet static
  address 172.251.1.86
  netmask 255.255.255.248
  network 172.251.1.80    #(tried with and without)
  broadcast 172.251.1.87  #(tried with and without)

The other interfaces are classical, static declarations. bridge-utils is installed but no br-device is enabled.

After ifup:

2: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP qlen 1000
    link/ether e4:1f:13:6d:36:98 brd ff:ff:ff:ff:ff:ff
    inet 172.251.1.86 peer 172.251.1.1/29 brd 172.251.1.87 scope global eth2
    inet6 fe80::e61f:13ff:fe6d:3698/64 scope link 
       valid_lft forever preferred_lft forever

I expect this route to be added automatically:

...
172.251.1.80    0.0.0.0         255.255.255.248 U     0      0        0 eth2
...

But this route is added:

...
172.251.1.0     0.0.0.0         255.255.255.248 U     0      0        0 eth2
...

Of course I can add some up-lines to the interfaces file to fix the routes. I'm just wondering if I am missing something. Maybe some cache to flush, a typo I am missing since hours, or just a misunderstanding.

Thanks in advance

share|improve this question

1 Answer 1

up vote 0 down vote accepted

I suspect your problem is related to the peer 172.251.1.1/29 shown in the ip addr output, though there is nothing in the configurations you have shown which indicate where this is coming from.

Check through your configurations for references to 172.251.1.1/29 as this will likely then point you to the ultimate source of your problem.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.